Disk Quota exceeded by activating environment

Hello everybody,

I worked now for 6 months with julia and everything was fine, but I receive now a error callstack that is not understandable to me.
I work via ssh on a ubuntu server, and there I received the following error message if I want to activate an environment or run a script:

The error message says that it would have exceeded the disk quota, but that’s not true , I have still enough space left on the drive, I was able to copy still 100gb of videos on it.
The message appears independent of the environment or script I would like to run.
Additionally the scripts and environment still run on the other server which has the same mirrored drive (but this one has less cores, so I would like to stay on the one where it doesn’t work :wink: ).
And the same scripts and environment run already several times on this server.

The only thing I could find to the topic in the forum was this:

But this did not help in my case.
Has anybody an idea, wehre this comes from?

Thanks in advance!
Moritz

Two ideas:

Did you make sure you were logged in with the same user when you copied the video files?

Check that this is not an inode related issue, you can use df -i for that.

1 Like

Hey,

thank you for your answer.
Unfortunately this did not solve my issue.
But I deleted the logs folder in the /.julia folder, and this solved my problem.

It sounds like your quota is restricted by the number of files, not just usage quota - maybe something to keep in mind when you run into this again.

1 Like