Dependency Struggle in Local Registry

I’m part of a small group maintaining our own registry for packages that are too specialised or not mature enough for General. Occasionally there are hiccups in managing dependencies, and here is another one - I hope somebody can point me in the right direction:

This concerns the package ASE.jl.

# A/ASE/Dep.toml
Requires = "ae029012-a4dd-5104-9daa-d747884805df"

I then start a new project in scratch and add only ASE to it:

# scratch/Project.toml
ASE = "51974c44-a7ed-5088-b8be-3e78c8ba416c"

# scratch/Manifest.toml
deps = ["JuLIP", "LinearAlgebra", "NeighbourLists", "Parameters", "PyCall", "Reexport"]
git-tree-sha1 = "b405cc94aa9f3a325e8d5b5e20717be899cec05a"
uuid = "51974c44-a7ed-5088-b8be-3e78c8ba416c"
version = "0.5.3"

# .... and many others .....

Why does Requires not get listed in the dependencies? This is currently causing all my tests to fail. I tried to resolve, rm Manifest.toml, nothing I do seems to fix this?

Thanks in advance for any advise!

Bump - does anybody have any thoughts what might cause this to help me debug?

Try with the 1.5 beta. It contains some fixes for the case of working with multiple registries.

Great, will do. I just installed it.

Behaviour has improved, it now fails more gracefully, but still fails on Julia v1.5; see below. I tried to register another artificial version but the behaviour remains the same.

(@v1.5) pkg> activate .
 Activating new environment at `~/.julia/dev/scratch/Project.toml`

(scratch) pkg> add ASE

# ... lots of stuff happening ... 

(scratch) pkg> status
Status `~/.julia/dev/scratch/Project.toml`
  [51974c44] ASE v0.5.3

(scratch) pkg> test ASE
    Testing ASE
Status `/private/var/folders/6_/0g4_trws39v6l0lyfpygjpzr0000gn/T/jl_zH1qZN/Project.toml`
  [51974c44] ASE v0.5.3
  [945c410c] JuLIP v0.9.3
  [2fcf5ba9] NeighbourLists v0.5.1
  [d96e819e] Parameters v0.12.1
  [438e738f] PyCall v1.91.4
  [189a3867] Reexport v0.2.0
  [ae029012] Requires v1.0.1
  [37e2e46d] LinearAlgebra
  [8dfed614] Test
Status `/private/var/folders/6_/0g4_trws39v6l0lyfpygjpzr0000gn/T/jl_zH1qZN/Manifest.toml`
  [51974c44] ASE v0.5.3
  [2169fc97] AlgebraicMultigrid v0.3.0
  [4fba245c] ArrayInterface v2.8.7

# .... many lines removed .... 

  [8dfed614] Test
  [cf7118a7] UUIDs
  [4ec0a83e] Unicode
┌ Warning: Package ASE does not have Requires in its dependencies:
│ - If you have ASE checked out for development and have
│   added Requires as a dependency but haven't updated your primary
│   environment's manifest file, try `Pkg.resolve()`.
│ - Otherwise you may need to report an issue with ASE
└ Loading Requires into ASE from project dependency, future warnings for ASE are suppressed.
  Testing ASE.jl

# .....  the tests all pass - no problem.