Conda.jl: specify library version

My package, ScikitLearn.jl, is not yet compatible with the latest scikit-learn library. Is there any way to specify that via Conda.jl? Alternatively, what’s the easiest way to Conda.add("scikit-learn", some_version_number)? I see the env argument, but I’m not much of a Python user anymore…

@Albert_Zevelev This is a question that any Python-interoped package faces, with no relation to ML, so I brought back the usage category

2 Likes
julia> Conda.add("scikit-learn=0.23")
[ Info: Running `conda install -y scikit-learn=0.23` in root environment
Collecting package metadata (current_repodata.json): done
Solving environment: done

## Package Plan ##

  environment location: /home/mose/.julia/conda/3

  added / updated specs:
    - scikit-learn=0.23


The following packages will be downloaded:

    package                    |            build
    ---------------------------|-----------------
    scikit-learn-0.23.2        |   py37h0573a6f_0         5.0 MB
    ------------------------------------------------------------
                                           Total:         5.0 MB

The following packages will be DOWNGRADED:

  scikit-learn                        0.24.1-py37ha9443f7_0 --> 0.23.2-py37h0573a6f_0



Downloading and Extracting Packages
scikit-learn-0.23.2  | 5.0 MB    | ############################################################################################### | 100% 
Preparing transaction: done
Verifying transaction: done
Executing transaction: done
2 Likes