I’m getting this error and I have no idea what it means. What is this?

remote: Permission to sloisel/MultiGridBarrier.jl.git denied to github-actions[bot].
fatal: unable to access '': The requested URL returned error: 403

Permissions error could be due to lacking write permissions, see CompatHelper.jl/.github/workflows/CompatHelper.yml at master · JuliaRegistries/CompatHelper.jl · GitHub example, specifically

  contents: write
  pull-requests: write

You can also check the default permissions for actions in the repository from “Settings → Actions → General → Workflow Permissions” at the bottom.

1 Like

Thanks for your reply. I’ve changed some github permissions I don’t understand and I’ll try to make it work for another couple of days but I guess if I fail, I can just turn off CompatHelper anyhow? I’m not even sure I know what it does…

OK that worked but now it says “Note: I have not tested your package with this new compat entry.
It is your responsibility to make sure that your package tests pass before you merge this pull request.”

How do I cause github to run my tests on this PR?

Edit: here’s one of the PRs



IIRC you need to have a properly configured deploy key set up in the github settings. By default github actions cannot create new actions, so compathelper cant start CI without additional setup. See section on “creating SSH key” on Home · CompatHelper.jl

I see that you are passing your documenter key into the compathelper environment via: COMPATHELPER_PRIV: ${{ secrets.DOCUMENTER_KEY }}
If the documenter key is set up with a deploy key and repository secret then I think this is supposed to work.

1 Like

I have a DOCUMENTER_KEY in my “Repository Secrets”, is that what you mean? Also I don’t know if it’s related, but the documentation seems to work on github for my project. Is that what you mean?

Edit: on my “Deploy Keys” tab, I have a “Documenter” deploy key with “read/write”.

OK well I gave up for now. Chasing this down is not worth the effort for me…

If you decide to try again, here is an example

I think you need both an access key as well as the GitHub token.

Thanks for this. I don’t know if what I had was exactly the same but I’ll look this up in the future if I want to use it again.