Can't seem to change PyPlot latex font

I’m trying to recreate a plot I made in Python (attached) using PyPlot in Julia.
I can’t seem to get the tick font and the x- and y- label fonts to match the ones in Python (Computer Modern I presume).

Here are the RC settings:

rcParams = PyPlot.PyDict(PyPlot.matplotlib."rcParams")
rcParams["text.usetex"] = [true];
rcParams["mathtext.fontset"]  = "cm";

I tried setting usetex to false but it doesn’t make a difference.
I also tried these settings

PyPlot.matplotlib[:rc]("mathtext",fontset="cm")        #computer modern font 

but that doesn’t make a difference.

Any idea how to recreate the fonts on the Python plot using PyPlot?
My Python Matplotlib settings are as follows:

plt.rc('text', usetex=True)

Shouldn’t this be rcParams["text.usetex"] = true? Why are you using an array [true] here?

The corresponding thing in Julia is:

plt.rc("text", usetex=true)
PyCall.PyDict(plt."rcParams")["text.latex.preamble"] = [raw"\usepackage{amsmath}"]

Gah! That was it! (true instead of [true])
I was confused because it was rendering some fonts fine, but the others were off.
Thanks for catching the typo.