Can't run Pluto

I can’t run Pluto:

[c3e4b0f8] Pluto v0.14.5
julia version 1.5.4

using Pluto

ERROR: LoadError: ArgumentError: invalid base 10 digit 'n' in "null"
 [1] tryparse_internal(::Type{Int64}, ::String, ::Int64, ::Int64, ::Int64, ::Bool) at /nix/store/33xjx0n6r2v7g079xb1d63i00b3s609k-julia-1.5.4/lib/julia/
 [2] parse(::Type{Int64}, ::String; base::Nothing) at /nix/store/33xjx0n6r2v7g079xb1d63i00b3s609k-julia-1.5.4/lib/julia/
 [3] parse at ./parse.jl:238 [inlined]
 [4] default_number_of_threads() at .julia/packages/Pluto/yDJcG/src/Configuration.jl:91
 [5] Pluto.Configuration.CompilerOptions() at ./none:0
 [6] field_default at ./none:0 [inlined]
 [7] field_defaults(::Type{Pluto.Configurat .julia/packages/Configurations/S1RPp/src/reflection.jl:17
 [8] from_dict_validat .julia/packages/Configurations/S1RPp/src/parse.jl:106
 [9] from_kwargs(::typeof(Configurat .julia/packages/Configurations/S1RPp/src/parse.jl:74
 [10] from_kwargs at .julia/packages/Configurations/S1RPp/src/parse.jl:72 [inlined]
 [11] #from_field_kwargs#8 at .julia/packages/Configurations/S1RPp/src/parse.jl:96 [inlined]
 [12] from_field_kwargs at .julia/packages/Configurations/S1RPp/src/parse.jl:96 [inlined]
 [13] #from_flat .julia/packages/Pluto/yDJcG/src/Configuration.jl:117 [inlined]
 [14] from_flat .julia/packages/Pluto/yDJcG/src/Configuration.jl:117 [inlined]
 [15] #run#224 at .julia/packages/Pluto/yDJcG/src/webserver/WebServer.jl:87 [inlined]
 [16] run() at .julia/packages/Pluto/yDJcG/src/webserver/WebServer.jl:87
 [17] top-level scope at src/experiments/web/src/wgl01.jl:3
in expression starting at src/experiments/web/src/wgl01.jl:3

Can you try using Julia 1.6?


Yes that works. Is there a compatibility policy?

It should be compatible with Julia 1.0 to 1.6. See Pluto.jl/Test.yml at main · fonsp/Pluto.jl · GitHub
Did you use a 32 bit version? I think only 64 bit versions are supported.

Experienced the same issue today with Julia 1.7.1:

ERROR: ArgumentError: invalid base 10 digit 'a' in "auto"

I think, it has to do with my environmental variables:


Setting it to 4 or any other number works.