Cant read any kind of file exclusively in vscode

hi, my code cant read any kind of file while i am using vscode. i have tried all kinds of files and when i use jupyter notebook, i have no problem like this.

What extension the files you use in the Jupyter Notebook have? .ipynb? If yes, this is a extension just for Jupyter Notebook use. Check out about the Jupytext extension to save notebook files as .jl files with some comments to separate the cells.

Can you tell us more about your setup? Do you have the VS Code isolated in some way, where it might need extra permissions to access the filesystem? What OS is this on, and what’s the code you’re using to read the files?

hi, im on windows and i think the problem is caused by vscode being isolated as well (but i dont know how i should be looking for this) because the code cant read like most probably any kind of file. the code i am using are like the basic read codes for CSV kind of packages.

If you’re on Windows, it’s not very likely that some kind of isolation is the problem, unless you’re running it on Docker or something (I was thinking maybe you were running it as a Linux AppImage or Flatpak type thing, but that doesn’t apply here).

Maybe it’s just a path issue. Can you show the exact code you’re using to read the files, and what error messages you get when you try to run them under VS Code?

i have this, d = XLSX.readtable, then this C = like i have tried reading 8-9 types of file.
AssertionError: File zillow_data_download_april2020.xlsx not found. and this is the error i get. and like i said in the main post, i dont get an error like this when i use jupyter notebook.

Have you made sure you are in the directory you think, e.g. @show pwd(), and that the path you use is a path to something that should exist, e.g. ispath(path)?

Could it be something with using backslash/forwardslash for paths?

yeah that seems to be the problem but it used to work well a week ago. can it change by itself like that?

thanks to you both btw

Changed by itself seems strange, but maybe if something was automatically updated. What exactly is it that changed?

If you’re sending just the filename "zillow_data_download_april2020" to XLSX.readtable, try passing in the whole path to the file instead.

i didnt have this kind of problem before so the pathway changed i guess

yep, that works