Can't install "MultivariateMoments", error: unable to automatically install "XML2"

Hi, I was trying to install the package “MultivariateMoments”.

import Pkg; Pkg.add("MultivariateMoments")

It failed with the following error:

Unable to automatically install 'XML2' from '/Users/My_Name/.julia/packages/XML2_jll/QkZTc/Artifacts.toml'

What should I do to fix this? Thanks in advance!

I then installed the “DebugArtifacts” package and tried the following:

using DebugArtifacts

However, I’m getting the following error:

Could not download to /var/folders/zh/731yt5nd0373pfdd6pcwn09m0000gn/T/jl_TSW0qm/Artifacts.toml:
ProcessFailedException(Base.Process[Process(`curl -C - '-#' -f -o /var/folders/zh/731yt5nd0373pfdd6pcwn09m0000gn/T/jl_TSW0qm/Artifacts.toml -L`, ProcessExited(51))])

Are you behind a firewall or something like that? it looks like you can’t access GitHub

I don’t think so. I can access my repositories without any problem. Although, it is very weird that I just ignored the error I got from debug_artifact("XML2") and tried again using MultivariateMoments. It just worked.

Maybe a temporary error? Do you still get the same error when trying to run debug_artifact?

I still get the same error while running debug_artifact("XML2")

Can you visit with your brower?

Yes, I can view this link. It looks like

arch = "aarch64"
git-tree-sha1 = "4adb90df7937269b13c71622da61692844573464"
libc = "glibc"
os = "linux"

    sha256 = "bacd995836fb5c8230ee1641d76faf4a2ddf196382203595694ff909d22f03f7"
    url = ""
arch = "aarch64"
git-tree-sha1 = "f4c5b9139bba8533e9e0752f3ba97ce6a6c2f770"
libc = "musl"
os = "linux"

Ok, looking better to the error message, curl here returned 51, which should be an error relative to certificates.

Anyway, glad that you manage to install the package :slightly_smiling_face: