Can't get DataFrames and IndexedTables working together.. in Juno!

juno
dataframes

#1

using DataFrames, IndexedTables

  • REPL, Jupyter or even Juno embedded REPL ==> all fine
  • Juno code area (“SHIFT-ENTER”) ==> Juno remains stuck with the gear forever

Julia 1.0.2 and latest packages


#2

Does evaluating the using DataFrames, IndexedTables line cause Juno to hang or constructing a DataFrame or whatever? I can’t repro this for either case.


#3

just evaluating using DataFrames, IndexedTables

(v1.0) pkg> status
    Status `~/.julia/environments/v1.0/Project.toml`
  [c52e3926] Atom v0.7.12
  [6e4b80f9] BenchmarkTools v0.4.1
  [336ed68f] CSV v0.4.3
  [a93c6f00] DataFrames v0.16.0
  [1313f7d8] DataFramesMeta v0.4.0
  [864edb3b] DataStructures v0.15.0
  [0c46a032] DifferentialEquations v5.3.1
  [7073ff75] IJulia v1.15.2
  [6deec6e2] IndexedTables v0.10.0
  [e5e0dc1b] Juno v0.5.4
  [aba2b823] LAJuliaUtils v0.0.0 [`~/.julia/dev/LAJuliaUtils`]
  [2fda8390] LsqFit v0.6.0
  [51fcb6bd] NamedColors v0.2.0
  [56b0d19f] OdsIO v0.4.0
  [91a5bcdd] Plots v0.22.5
  [d330b81b] PyPlot v2.7.0
  [60ddc479] StatPlots v0.8.2
  [24249f21] SymPy v0.8.3
  [c2297ded] ZMQ v1.0.0

#4

I solved installing julia 1.0.3 (without resetting ~/.julia) … I don’t think it is the upgrading to julia 1.0.3 that solved the problem, but rather the fact that it forced recompilation of the packages.