Can't connect Julia to Jupyter Notebook

#1

Hello,

I’ve posted this to github, but I was directed to this place. Wasn’t sure about where to post it exactly so I hope Usage is fine.

I’m having issues with connecting Julia to Jupyter Notebook. I’ve been following this guide but a problem occurs at the point where I have to type Pkg.add(“IJulia”) or when pressing ] first and then typing add IJulia.
A progress bar appears saying “Fetching”, goes from 0 to 100%, nothing happens for about 40-50 seconds and then this SystemError appears

To even begin with writing Pkg.add(“IJulia”) I had to first write import Pkg otherwise it’d say the following:

julia> Pkg.add(“IJulia”)
ERROR: UndefVarError: Pkg not defined
Stacktrace:
[1] top-level scope at none:0

I’m relatively new to programming, completely new when it comes to Julia, and definitely clueless when it comes to troubleshooting. I haven’t found any way to solve this issue, haven’t found any similiar problems in google, nor do I understand what the problem exactly is.

I’ve tried reinstalling it in directories different than the ones suggested by installation wizard, in both cases the same issue reoccurs.

Does anyone have an idea about what could I do about this?
Thanks for your help,
kind regards

0 Likes

#2

I’m not sure what went wrong, but what I would do is start with a fresh install of Julia (delete C:\Users\jakub\.julia) and then run:

julia> using Pkg

julia> Pkg.add("IJulia")

If there are still errors, post the output of that (from the first attempt).

1 Like

#3

Thanks for your quick answer, but I’m not sure I quite understand what you want me to do - am I supposed to reinstall Julia, and then first thing I do is write what you wrote?

0 Likes

#4

Not sure if I can edit a previous reply that did not get approved by a moderator yet, so I’ll just write another one. I’ve uninstalled Julia, removed the folder, installed it in a different one than previously and then using the command you’ve suggested it worked! That’s a big relief. Thank you very much :smiley:

0 Likes