Cannot type "@" in Jupyter notebooks with macOS Swiss German keyboard layout

When using Julia in Jupyter Notebook, if I want to type “@” in the cell (for example @variables), key kombination alt + G on my mac is somehow reserved for a shortcut " Jump to line…", so I am not able to type a literal @.
Displaying all shortcuts with “h” is not working. how can I disable that shortcut

Can you share more context? What kind of keyboard do you have? What OS?

On my computer, I type @ using shift + 2.

1 Like

Mac OS, keyboard language Swiss German, I use “alt + G” to type @

This is an open Jupyter issue: Impossible to type an "@" in a code cell on MacBook with Swiss keyboard layout · Issue #9801 · jupyterlab/jupyterlab · GitHub

Apparently a possible workaround is by overriding alt-g with a custom keyboard shortcut.

1 Like