Cannot add any packages under Julia 1.5.3 (Windows 10)

I am using Julia 1.5.3 under Windows 10, and cannot add any packages. The problem is not a misspelt package name. I have been able to add packages with all previous versions. I notice that, when attempting to add packages, my screen flickers for the briefest instant, and suddenly, I am thrown into Powershell. After that, I get the message

"ERROR: The following package names could not be resolved:

  • Makie (not found in project, manifest or registry)"

. Others have reported this behavior. The solutions suggested in those cases are beyond my ken or desire to implement. I can progress further within Juliapro, but then encounter other problems. The firewall at my company precludes me from circumventing that problem.

I can, of course, revert to a previous version of Julia. However, my preference is not to do that. Do I simply forego using this version of Julia, use R, and hope the problem is solved in the next version?

Can you start with a clean slate? The default environment?

Please excuse me if my questions sound simplistic. To the best of my knowledge , I am starting with “a clean slate? The default environment?” I downloaded and installed Julia 1.5.3. No other gyrations. That is it. I can enter “numbers” at the prompt, elementary arithmetic, sums, means, elementary statistics, etc

I see. I understood (perhaps misunderstood) that you used to use Julia in some earlier version, and hence I assumed that you tried to instantiate an environment which referred to Makie.

But if the problems appear when simply trying to start Julia for the first time, then perhaps it has to do with your access to the Internet. It is needed to retrieve the registry. There is a mention of firewall in your OP: does that limit what you can access from your computer?

Dear Petr:

I am able to start Julia. In previous Julia versions I have been able to add Makie and sundry other packages.

Yes, my company I am precluded from accessing many websites and software repositories.

I am personally not using Makie at the moment, but in the past I’ve had a lot of trouble installing it and/or the auxiliary packages.

It is possible that some packages don’t work with 1.5.3. At the moment everything works for me, but for instance I cannot switch to 1.6 because of one package that I need does not work with that release.

So what about just a basic Julia prompt? Do you get that to work?

When the installation of subsequent packages fails, then the best course of action is to let the people who are responsible for those packages on Github know that you are having difficulties. More often than not that results in prompt action, and your troubles may well be resolved in a day or two.