Building SCIP error

Hi, I’m trying to add the SCIP package to solve some optimization problems. I am using Ubuntu 18.04 and I installed SCIP already. But when I try to make the"SCIP") I get the next error message:

  Building SCIP → `~/.julia/packages/SCIP/hrirX/deps/build.log`
┌ Error: Error building `SCIP`: 
│ ERROR: LoadError: Unable to locate SCIP installation.
│ Tried:
│       /usr/bin/local/bin/
│       /usr/bin/local/lib/
│ Note that this must be downloaded separately from
│ Please set the environment variable SCIPOPTDIR to SCIP's installation path.
│ Stacktrace:
│  [1] error(::String) at ./error.jl:33
│  [2] top-level scope at /home/arielxx/.julia/packages/SCIP/hrirX/deps/build.jl:48
│  [3] include at ./boot.jl:328 [inlined]
│  [4] include_relative(::Module, ::String) at ./loading.jl:1094
│  [5] include(::Module, ::String) at ./Base.jl:31
│  [6] include(::String) at ./client.jl:431
│  [7] top-level scope at none:5
│ in expression starting at /home/arielxx/.julia/packages/SCIP/hrirX/deps/build.jl:47
└ @ Pkg.Operations /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v1.2/Pkg/src/backwards_compatible_isolation.jl:647

I have tried with different julia versions and it’s the same. I installed SCIP doing make installso I don’t have the location of the file and can’t set the environment variable SCIPOPTDIR.

Please, any help will be appreciated. Thanks

If you used the cmake install procedure (recommended, I believe), the default install location should be /usr/local, so that’s what SCIPOPTDIR should be set to (haven’t checked, but pretty sure). You can also run updatedb (probably requires sudo) to update the locate database, followed by locate to make sure ( will be in the lib subdirectory of SCIPOPTDIR). You can also use cmake -D CMAKE_INSTALL_PREFIX=/whatever/directory .. instead of cmake .. to control where SCIP is installed, so that SCIPOPTDIR=/whatever/directory.


Yes, you were absolutely right. Thank you very much

1 Like