A question about SCIP in Julia

 Error: Error building `SCIP`: 
│ ERROR: LoadError: Unable to locate SCIP installation.
│ Tried:
│       scip.dll
│ Note that this must be downloaded separately from scip.zib.de.
│ Please set the environment variable SCIPOPTDIR to SCIP's installation path.
│ Stacktrace:
│  [1] error(::String) at .\error.jl:33
│  [2] top-level scope at C:\Users\dell\.julia\packages\SCIP\ZO1uK\deps\build.jl:48
│  [3] include at .\boot.jl:328 [inlined]
│  [4] include_relative(::Module, ::String) at .\loading.jl:1094
│  [5] include(::Module, ::String) at .\Base.jl:31
│  [6] include(::String) at .\client.jl:431
│  [7] top-level scope at none:5
│ in expression starting at C:\Users\dell\.julia\packages\SCIP\ZO1uK\deps\build.jl:47
└ @ Pkg.Operations C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.2\Pkg\src\backwards_compatible_isolation.jl:647

I tried so many ways,but I cannot find how to deal with it.Please, any help will be appreciated. Thanks

just to clarify, did you try doing this? It would be useful if you describe exactly how did you try to solve this problem.

Not sure if you saw but it seems that there are some previous posts about this problem here in discourse and in the github repo that might help you.

1 Like

I have already do this but it do not work :weary:

I’m not sure if this will be helpful for you, but when I was trying to get SCIP to work I found that using the installers (shown in the red box below) was much easier than trying to build from source (if that is what you were trying to do).


Excuse me if I revive this topic, but I’m having the same issue and I don’t know how to fix it…
I used the installer that you mentioned (for windows) but the same error keeps coming out.
Does anyone know a solution?

Have you added the binary to your PATH? I’m not sure how to do it on windows, but I bet that has to be done manually as well.

In the list that I find opening Path (in the system variables) is present C:\Program Files\SCIPOptSuite 7.0.1\bin
In addition, I tried to add an user variable named SCIPOPTDIR (with value C:\Program Files\SCIPOptSuite 7.0.1) but nothing changed…

What os the output of:

] build SCIP

And what are your package versions?

] status
1 Like

Ok, I have good news.
The commands suggested by @joaquimg led to outputs without any kind of errors, therefore I tried again to load my optimization problem with SCIP as optimizer and JuMP managed to do it successfully. I think that the error that I kept receiving after the addition of the user variable SCIPOPTDIR was only due to the fact that Julia was working while I added the variable and a restart was needed.

For now, my problem seems to be solved, thank you very much for your support @JosiahPohl and @joaquimg!

1 Like