Build for Julia nightly fails due to `DelimitedFiles.jl`

Hi there,

I have two packages for which the build on Julia nightly keeps failing recently. For both of them I get the same error message,

┌ Warning: The active manifest file has dependencies that were resolved with a different julia version (1.8.1). Unexpected behavior may occur.
└ @ ~/work/ConformalPrediction.jl/ConformalPrediction.jl/Manifest.toml:0
ERROR: Could not locate the source code for the DelimitedFiles package. Are you trying to use a manifest generated by a different version of Julia?
  [1] pkgerror(msg::String)
    @ Pkg.Types /opt/hostedtoolcache/julia/nightly/x64/share/julia/stdlib/v1.9/Pkg/src/Types.jl:68

see here and here for details.

I figured it may have something to do with dependencies, but at least in terms of direct dependencies there’s actually no overlap here:

(ConformalPrediction) pkg> st
Project ConformalPrediction v0.1.0
Status `~/code/ConformalPrediction.jl/Project.toml`
  [add582a8] MLJ v0.18.5
  [10745b16] Statistics

(ConformalPrediction) pkg> activate LaplaceRedux.jl/
  Activating project at `~/code/LaplaceRedux.jl`

(LaplaceRedux) pkg> st
Project LaplaceRedux v0.1.0
Status `~/code/LaplaceRedux.jl/Project.toml`
⌃ [31c24e10] Distributions v0.25.73
  [587475ba] Flux v0.13.6
  [d96e819e] Parameters v0.12.3
⌃ [91a5bcdd] Plots v1.33.0
  [e88e6eb3] Zygote v0.6.49
  [37e2e46d] LinearAlgebra
  [9a3f8284] Random
Info Packages marked with ⌃ have new versions available

Have tried upgrading the Manifests, resolving, (re-)instantiating … but nothing seems to help.

Any ideas what’s going wrong? :slight_smile:

Looks like you’re checking in the Manifest files, which is somewhat unusual for packages, although common for projects. Is this important for your package?

1 Like

Ahh I’m an idiot, not sure why/when I changed my .gitignore. Thanks for the quick response!