The following package names could not be resolved

I have no idea how to use the new Pkg system (correctly) so I am just going to describe the things I did and the things I want to have happened and maybe you guys can lead me down the right path:

On a fresh install of julia v1.0 I add a new (unregistered) package by doing

Pkg.clone("url", "Foo")

now I know that i should instead be doing ]dev "url" but my url is mangled because of bitbucket so I want to pass in the correct name of the package and I don’t see an option with dev to do that

anyways. I actually want a particular branch of this project so outside of julia I git checkout mybranch which has some different packages in REQUIRE

in julia then if I do ]resolve I get something like:

 Resolving package versions...
ERROR: The following package names could not be resolved:
 * DelimitedFiles (8bb1440f-4735-579b-a4ab-409b98df4dab in manifest but not in project)
Please specify by known `name=uuid`.

so where have I strayed wrong, or how do I move forward from here?

Got it, DelimitedFiles shouldn’t have been in REQUIRE because it is in the stdlib. all fixed


I’m running into a very similar error and am wondering if you could elaborate on your solution (or suggest a different path).

Description of set-up:
I’m running on Julia 1.2 with Atom 1.40.1.
I downloaded a project from gitlab, which includes a Project.toml and Manifest.toml file.
I have cd’ed to the correct folder and then done “] activate .” and “] instantiate”

The error I get is:
“ERROR: Package CredentialsHandler [864e158e-919d-11e8-198e-cfe890ec4681] not found in a registry”

I tried removing the CredentialsHandler from Manifest.toml (I know, a bad idea) and got “ERROR: Dependency on CredentialsHandler but no such entry in manifest” upon running the “]st” command.

I tried “]add CredentialsHandler” but (1) it’s in stlib, so I shouldn’t need to and (2) I got the standard could not resolve package error.

Current theory: the Manifest and Project.toml files were created under an older (1.1 I think?) version of Julia, so that might be causing the issue. So I might be able to just create new toml files using v1.2 and have the problem solved. But this would mean every time someone wants to use the project with a different version of julia, the toml files are useless. Any ideas on better options?

I tried adding the packages I needed manually (e.g., Plotly) which led to an error of some other packages not being found (“ERROR: path e.g., [path].julia\packages\CacheVariables\JZbwi for package CacheVariables no longer exists. Remove the package or develop it at a new path”)

After removing the packages that the error mentioned, the “] instantiate” now works. I still don’t have a full explanation, but I’m guessing it has something to do with updating the julia version and/or switching from JuliaPro to Atom+Juno. Not sure why it showed up as an error with CredentialsHandler though.

Have you tried Pkg.update?

I vaguely recall a similar situation (also with CredentialsHandler) and that worked for me. Unfortunately, I don’t recall more detail.