Beta Gadfly available for 1.0


#1

before tagging a release we’d like to get feedback from field testers to see if there are any issues. please checkout the master branch of both Gadfly and Compose.


#2

Thanks for your work! I’m on Julia 1.0 and was just trying to run some of the plots in the documentation. One that doesn’t currently work for me is:

p1 = plot([sin,cos], 0, 2pi)

I get the following error:

Error showing value of type Plot:
ERROR: MethodError: no method matching IndirectArrays.IndirectArray(::Array{Union{Nothing, Int64},1}, ::Array{String,1})
Closest candidates are:
IndirectArrays.IndirectArray(::AbstractArray{#s12,N} where #s12<:Integer, ::AbstractArray{T,1}) where {T, N} at C:\Users\jduncan.RC.julia\packages\IndirectArrays\0Jc04\src\IndirectArrays.jl:26
IndirectArrays.IndirectArray(::AbstractArray) at C:\Users\jduncan.RC.julia\packages\IndirectArrays\0Jc04\src\IndirectArrays.jl:33

This is on Windows by the way. Again thanks for the work updating the package.


#3

@nalimilan might have just fixed that. please pull and try again.


#4

Looks like it works now. Great, thanks!


#5

I tried a couple of basic plots and it works just fine. Thanks for doing the update!


Julia 1.0 support just landed on Gadfly master