Atom Juno won't open Julia if directory path contains spaces

juno

#1

I tried to switch to using the atom-integrated REPL in the latest Juno patch. However, it doesn’t seem to work with a space in the Julia directory path (this is on Windows).

The full path is: C:\Users\Clinton Name\AppData\Local\Julia-0.6.2\bin\julia.exe

If the path in the settings has no quotes, I get this error:

ERROR: could not open file C:\Users\Clinton
Stacktrace:
[1] include_from_node1(::String) at .\loading.jl:576
[2] include(::String) at .\sysimg.jl:14
[3] process_options(::Base.JLOptions) at .\client.jl:305
[4] _start() at .\client.jl:371

If I add quotes around the path, I get this error message:

We tried to launch Julia from:
“C:\Users\Clinton Name\AppData\Local\Julia-0.6.2\bin\julia.exe"
This path can be changed in the settings.
Details:
’”"C:\Users\Clinton’ is not recognized as an internal or external command,
operable program or batch file.

Launching the REPL directly from windows works fine, as does using the now called “legacy” console in Atom (as it did before the patch).


#2

Should be fixed with https://github.com/JunoLab/atom-julia-client/commit/a861add9448abc291967f04abc08b235638631f7. Sorry for the inconvenience :slight_smile:


#3

Thanks for the fast turn around!