I am working on a package for different Constraint-Based Local Search (CBLS) Solvers.
I am a bit at a loss on how to name it.
- CBLS.jl is hard to understand outside of the community. Same for CBLSSolvers.jl
- ConstraintBasedLocalSearchSolvers.jl is a bit long, making things annoying to use.
Do you need all those adjectives in the name, How about ConstrainedSolvers.jl or something?
We generally recommend people avoid acronyms in package names.
What about dropping just half of the adjectives? eg.
LocalSearchSolvers.jl is a pretty nice name.
I guess I will settle for LocalSearchSolvers.jl, even I will only implement some constraint-based ones
Thank you, all!