"add Plots" giving error

Hi,
I have updated to Julia 1.6.4. All the package installations go fine except the “Plots” package. I get the following error/warning while installing Plots:

 Installed Scratch ───────── v1.1.0
ERROR: Unexpected end of data : jl_nr4uH7QiJ7VLq8Ix~ ]  14/16
   Installed IterTools ─────── v1.3.0
┌ Warning: failed to extract archive downloaded from https://pkg.julialang.org/package/35d6a980-a343-548e-a6ea-1d62b119f2f4/a851fec56cb73cfdf43762999ec72eff5b86882a
└ @ Pkg.Operations C:\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.6\Pkg\src\Operations.jl:596
   Installed ColorSchemes ──── v3.15.0

Is there any way to fix this?
Thanks and regards
Majid