What causes the Distributed.ProcessExitedException(3) error in Julia and how can I resolve it in my Pluto notebook?

I am encountering the Distributed.ProcessExitedException(3) error in my Julia Pluto notebook. I am not sure what is causing this error or how to resolve it. I have tried updating Julia and the Pluto package, as well as restarting the kernel, but the error persists.

Here is an example of the code that is causing the error:

MLJ.fit!(xgb_regressor, rows=train)

Can anyone help me understand what is causing this error and how I can resolve it? Thank you!

That’s not quite what I meant with my earlier response in the other thread. A Distributed.ProcessExitedException just means that there was an error on some worker process, but it doesn’t tell you anything about the error itself. You’ll need to provide a full stacktrace, or even better an MWE version of your notebook for people to give you any useful advice.

It could be running out of memory. Does it work if you use much less data (to diagnose)?

1 Like

Even if i reduce the data, i am still getting the same error

Here is the full stacktrace

Worker 2 terminated.
Unhandled Task ERROR: IOError: read: connection reset by peer (ECONNRESET)
[1] wait_readnb(x::Sockets.TCPSocket, nb::Int64)
@ Base .\stream.jl:410
[2] (::Base.var"#wait_locked#680")(s::Sockets.TCPSocket, buf::IOBuffer, nb::Int64)
@ Base .\stream.jl:947
[3] unsafe_read(s::Sockets.TCPSocket, p::Ptr{UInt8}, nb::UInt64)
@ Base .\stream.jl:953
[4] unsafe_read
@ .\io.jl:759 [inlined]
[5] unsafe_read(s::Sockets.TCPSocket, p::Base.RefValue{NTuple{4, Int64}}, n::Int64)
@ Base .\io.jl:758
[6] read!
@ .\io.jl:760 [inlined]
[7] deserialize_hdr_raw
@ C:\Users\martthomas\AppData\Local\Programs\Julia-1.8.5\share\julia\stdlib\v1.8\Distributed\src\messages.jl:167 [inlined]
[8] message_handler_loop(r_stream::Sockets.TCPSocket, w_stream::Sockets.TCPSocket, incoming::Bool)
@ Distributed C:\Users\martthomas\AppData\Local\Programs\Julia-1.8.5\share\julia\stdlib\v1.8\Distributed\src\process_messages.jl:172
[9] process_tcp_streams(r_stream::Sockets.TCPSocket, w_stream::Sockets.TCPSocket, incoming::Bool)
@ Distributed C:\Users\martthomas\AppData\Local\Programs\Julia-1.8.5\share\julia\stdlib\v1.8\Distributed\src\process_messages.jl:133
[10] (::Distributed.var"#103#104"{Sockets.TCPSocket, Sockets.TCPSocket, Bool})()
@ Distributed .\task.jl:484