Warning message from `juliaup` after updating to Apple Silicon

This post is a summary of a Slack thread (thanks @davidanthoff) that I wanted to make more publicly available.

I recently upgraded to an M1 Pro MacBook from an older Intel model and started getting a strange message every time I opened a Julia REPL in VSCode:

The latest version of Julia in the `release` channel is 1.10.0+0.x64.apple.darwin14. You currently have `1.10.0+0.aarch64.apple.darwin14` installed. Run:

  juliaup update

to install Julia 1.10.0+0.x64.apple.darwin14 and update the `release` channel to that version.

But whenever I ran juliaup update in a regular REPL, the release tag pointed to the aarch64 version rather than the x64 version:

% juliaup list | grep release
 release                1.10.0+0.aarch64.apple.darwin14        
 release~aarch64        1.10.0+0.aarch64.apple.darwin14        
 release~x64            1.10.0+0.x64.apple.darwin14  

There were three factors at play:

  1. I had transferred all of the data from my old Mac to the new one, which meant an x64 version of VSCode as well. I downloaded the Apple Silicon version specifically, but continued to get the same error messages.
  2. I had installed juliaup using both the recommend installation script and Homebrew. To fix this, I ran brew uninstall juliaup and then confirmed that juliaup was still installed somewhere by running which juliaup.
  3. The settings in VSCode (Julia: Executable Path) had been changed (I canā€™t remember whether I did this myself a long time ago or not) to point to /usr/local/bin/julia, which is not the path used by juliaup. I reset this setting.

I did both 2 and 3 without testing in between, so Iā€™m not sure which one solved the problem, but the error messages are gone now. Moral of the story: take the warnings in the juliaup README about other installation methods seriously!

2 Likes