VS Code extension v0.8.0-beta.1 release


#1

Hi all
We’ve released a beta for the next version of the Julia VS Code Extension, v0.8.0-beta.1. We’d much appreciate it if we could get some testers to try it out and give feedback on bugs before we release it to the marketplace.

New features/changes include:

  • Complete overhaul/modularisation of the backend (CSTParser, DocumentFormat).
  • Improved speed: 5x speed up in parsing (many thanks to @kristoffer.carlsson and @Keno for work on CSTParser and Tokenize).
  • Improvements to the formatter (indents).
  • Eval in module: change the current terminal’s evaluating module using the Julia: Change REPL module command.
  • IntelliSense improvements: more accurate scoping of variables.
  • Find References/Rename Symbol: vast improvements in accuracy.
  • Hovers: hovering over an expression closing symbol -e.g. a ) or end- indicates which expression it refers to.
  • Deprecations: A subset of Julia v0.6 deprecations are detected and can be automatically fixed by clicking on the lightbulb that appears.
  • Ability to turn off linting by file.

Please send as many bug reports as you can our way at https://github.com/JuliaEditorSupport/julia-vscode.
Bugs I’m aware of or have fixed include:

  • Crashes on use of @enum. (fixed on master)
  • Crashes on no-arg string interpolation between triple quotes. (fixed on master)
  • Persistent ‘starting up’ message. (fixed on master)
  • Error locations not appearing. (Fixed on master)

Thanks to those who have already been testing!

To try the beta download the VSIX file from https://github.com/JuliaEditorSupport/julia-vscode/releases/download/v0.8.0-beta.1/language-julia-0.8.0-beta.4.vsix and install using the Extensions: Install from VSIX... command.

Thanks,
Zac and David


#2

Sometimes VS Code can get confused when you upgrade using VSIX (persistant ‘Reload’ button on the extension). To solve this you need to manually remove old versions and ‘Install from VSIX…’ again, the extension is usually installed in ~/.vscode/extensions


#3

I had this issue and manually removing the old versions solved this problem.

BTW: I use VS Code as my Julia editor and really enjoy its speed and features.


#4

We just release v0.8.0-beta.2 here. @ZacLN knows best what has changed relative to beta 1 (I think there are a few new features). Any feedback is welcome!


#5

And I missed an important PR before release beta 2. So, here is beta 3. Please test that one and just ignore beta 2.


#6

Perhaps update the link in the previous post.


#7

Here is beta 4, because we just had to release three betas in one day:

Sorry for the fast turnaround here, this will be the last one for a couple of days.

@ZacLN Can you update the original top post to reflect the new beta releases? I can’t edit that.


#8

yup done


#9

I commented on an issue that LaTeX autocompletions do not work for me on any of my three Ubuntu systems (1x 16.04 and 2x 17.04). I like the look and feel of VS Code, so I’d try it once that is fixed.

EDIT:
My settings messed it up. Apparently I set the same settings on all three systems.
Once I deleted the following setting (that I had added…), LaTeX autocompletions work:
“editor.tabCompletion”: true
Tab competitions work too.
Pretty bad debugging on my behalf.


#10

LaTeX autocompletions wors fine for me on all the linux systems I have used it on.


#11

My bad. Turning off:
“editor.tabCompletion”: true
in the settings fixed it.


#12

Kudos to the VS development team. The IDE is very usable and I am very happy with it.

If there are any newbies here, I posted a brief tutorial for setting up VS Code here: VS code is excellent!


#13

With this release should I expect PyPlot to work directly and produce a plot tab? I’ve only been able to get it to work through plots.jl.


#14

Not sure what is going on there, but we’re going to look into it: https://github.com/JuliaEditorSupport/julia-vscode/issues/325.


#15

Excellent. Thanks. It is a very nice extension that I’ve switched over to almost completely.


#16

I get into the Julia:busy state directly after typing something and my whole file looks like this

vscode-julia

It worked fine a couple of days ago but now it’s just unusable.
Any ideas how to fix it?


#17

Are you sure you aren’t missing an “end” somewhere in your code?


#18

Well that is the problem.
I just typed for i=1:10 and then everything turns red because an end is missing. If I add it, it doesn’t change back to normal and stays busy.


#19

I can’t replicate this issue. Can you show the whole script that causes this issue? I’m just wondering because you have red lines already on the line above the for loop.


#20

I just tested it on a new empty file and it seems quite fine there. It changes from busy to ready frequently.
My whole script is in a bigger project and quite long. Maybe processing it takes too long?

Edit:
So just fyi it takes about 30s of Julia: starting up and then it sometimes switches to ready and sometimes directly to busy. I have a REPL open outside of VS-code. (Just find it easier :smiley: )
If it’s ready and I do something it changes to busy and everything gets underlined.