Versioning in a new Julia package

I have created a Julia package, that I am trying to register at the General registry.

However, the pull request tests failed (twice now). This is the concerned AutoMerge test.

The error output is

ERROR: Unsatisfiable requirements detected for package TimetableSolver [df459030]:
 TimetableSolver [df459030] log:
 ├─possible versions are: 0.1.0 or uninstalled
 ├─restricted to versions 0.1.0 by an explicit requirement, leaving only versions 0.1.0
 └─restricted by julia compatibility requirements to versions: uninstalled — no versions left

And then, import <PackageName> also failed but I believe it may ultimately be because of this error.

This is my package on github: TimetableSolver.jl. In the Project.toml and using git tag I have listed version v0.1.0 for the package, and fixed all dependencies and compat to upper bounded.

My package is limited to julia = "~1.6" # [1.6.0, 1.7.0), because the last time I tested with 1.7 (latest) my code failed. Do I need to update Project.toml to work with 1.7 and test my code accordingly?

I found the solution.

For me, as soon as I updated my julia version from julia = "1.2 - 1.6" to julia = "~1.6" the checks succeeded and my package was added to the registry. Wasn’t really a change more of a bugfix.

For anyone else, who stumbles on this post with a similar question, remember to use appropriate versioning for dependencies (including julia) and your own package. See Compatibility for more info on how to do this properly.

1 Like

Well, that’s not what ^1.6 means. PackageCompatUI can be a useful tool to manage your compat settings and see what they effectively mean.


Oh, thanks. I realized I was using the wrong symbol, should fix that.
Thanks for the package link, it’s really useful.