Version of Pkg in JuliaPro 1.2.0 for Windows

Hi, In my company we have a local non-github based registry. In order for it to work we need to put this in our startup.jl:

import Pkg
Pkg.GitTools.setprotocol!(domain="...", protocol="ssh", user="...")

I am now trying to help a hardcore MATLAB-user to get started with Julia and to use a package of mine from our local registry. I recommended him to start off with JuliaPro to get Juno bundled and working from the start. So he did, with Julia 1.2.0.

He is located remotely, so our only communication is chat and mail. I can not log in to his box remotely.

But his installation does not contain the setprotocol! function that takes keyword arguments. I have tried it on my end with julia 1.2.0 and it works fine.

There are two differences between our installations: I run on Linux and use vanilla julia. My colleague runs on Windows and use JuliaPro.

Does anyone know if there is a different version of Pkg bundled with the Windows version of JuliaPro ?

And if so, can you upgrade Pkg ? Or somehow set the protocol components that Pkg uses to communicate with the registry ?

I got hold of a Windows box and downloaded JuliaPro 1.2.0-2 and can confirm that it comes with an older version of Pkg. Is that a mistake ?

EDIT: I also downloaded vanilla 1.2.0 for Windows and it comes with Pkg v1.2.0. So, it is only JuliaPro 1.2.0-2 for Windows that has this problem.