"using Plots" suddenly stopped working

I have been using Plots in Julia 1.0 for a whil now and it all worked ok. However, I needed some plots were I more easily could customize various things (line thickness etc.) to make a pretty figure and I thought I should use Plotly (which always gave me a good web interface for this kind of things in 0.6). Earlier in 1.0 I have only used GR to myself look at my data.

In principle I used add PlotlyJS in the pkg tool, realized that it didn’t worked at all, and returned to my old Jupyter notebook. This may not be related, but now I get this error whenever I run

using Plots
┌ Info: Precompiling Plots [91a5bcdd-55d7-5caf-9e0b-520d859cae80]
└ @ Base loading.jl:1186
WARNING: StaticArrays.FixedSizeArrays is deprecatedStaticArrays.FixedSizeArrays is deprecated. Use StaticArrays directly.
  likely near /home/Torkel.Loman/.julia/packages/Plots/Ufx0i/src/Plots.jl:8
ERROR: LoadError: LoadError: UndefVarError: FixedSizeArrays not defined
 [1] top-level scope at none:0
 [2] include at ./boot.jl:317 [inlined]
 [3] include_relative(::Module, ::String) at ./loading.jl:1038
 [4] include at ./sysimg.jl:29 [inlined]
 [5] include(::String) at /home/Torkel.Loman/.julia/packages/Plots/Ufx0i/src/Plots.jl:1
 [6] top-level scope at none:0
 [7] include at ./boot.jl:317 [inlined]
 [8] include_relative(::Module, ::String) at ./loading.jl:1038
 [9] include(::Module, ::String) at ./sysimg.jl:29
 [10] top-level scope at none:2
 [11] eval at ./boot.jl:319 [inlined]
 [12] eval(::Expr) at ./client.jl:389
 [13] top-level scope at ./none:3
in expression starting at /home/user_name/.julia/packages/Plots/Ufx0i/src/utils.jl:290
in expression starting at /home/user_name/.julia/packages/Plots/Ufx0i/src/Plots.jl:167

and this output

Failed to precompile Plots [91a5bcdd-55d7-5caf-9e0b-520d859cae80] to /home/user_name/.julia/compiled/v1.0/Plots/ld3vC.ji.

 [1] error(::String) at ./error.jl:33
 [2] macro expansion at ./logging.jl:313 [inlined]
 [3] compilecache(::Base.PkgId, ::String) at ./loading.jl:1184
 [4] macro expansion at ./logging.jl:311 [inlined]
 [5] _require(::Base.PkgId) at ./loading.jl:941
 [6] require(::Base.PkgId) at ./loading.jl:852
 [7] macro expansion at ./logging.jl:311 [inlined]
 [8] require(::Module, ::Symbol) at ./loading.jl:834
 [9] top-level scope at In[3]:1

I have tried to find a solution, but none found. I tried rm PlotlyJS in pkg, but didn’t seem to help.

Anyone knows what is going on?

It is temporarily broken by a change in a dependency (the StaticArrays dependency has no upper bound in the Plots REQUIRE and it did a breaking change in the last release). Should be fixed here (you can check out the PR or pin StaticArrays to an earlier version if you need to use Plots right now).

Thanks for the quick reply.