Unsatisfiable requirements for ForwardDiff on Julia 1.0

I am working with version 0.18.2+ of JuMP (JuMP 0.18 compatible with 1.0) and I get the following error when I do resolve:

ERROR: Unsatisfiable requirements detected for package ForwardDiff [f6369f11]:
 ForwardDiff [f6369f11] log:
 ├─possible versions are: [0.0.2-0.0.3, 0.1.0-0.1.8, 0.2.0-0.2.5, 0.3.0-0.3.5, 0.4.0-0.4.2, 0.5.0, 0.6.0, 0.7.0-0.7.5, 0.8.0-0.8.5, 0.9.0] or uninstalled
 ├─restricted to versions 0.5.0-0.8 by JuMP [4076af6c], leaving only versions [0.5.0, 0.6.0, 0.7.0-0.7.5, 0.8.0-0.8.5]
 │ └─JuMP [4076af6c] log:
 │   ├─possible versions are: 0.18.2 or uninstalled
 │   └─JuMP [4076af6c] is fixed to version 0.18.2+
 ├─restricted to versions 0.8.5 by an explicit requirement, leaving only versions 0.8.5
 └─restricted by julia compatibility requirements to versions: [0.1.3-0.1.8, 0.2.0-0.2.5, 0.3.0-0.3.4, 0.9.0] or uninstalled — no versions left

I’m pretty stumped here. Is this a bug?

(I see some old, similar issues which I don’t think are related)

The only way I can get this working at all is going into the JuMP REQUIRE and allowing it to use ForwardDiff 0.9. Obviously that’s not an ideal solution.

https://github.com/JuliaLang/METADATA.jl/pull/17516 perhaps

1 Like

Hm, so assuming this was fixed in METADATA, how do I resolve? Shouldn’t it work now? The merge happened 20 hours ago.

I meant the opposite, that that PR perhaps caused this :slight_smile:

1 Like

Oh I see, that was silly of me right, the bounds are like [a, b)?

Yes, if that’s the case than they definitely broke this (whether or not that’s the problem I’m seeing).

The README file for JuMP shows that JuMP v0.18.2 is not compatible with Julia v0.7/1.0.

Ok, I’m pretty sure @kristoffer.carlsson is right and that was the issue. I made a PR.

Yes I have fixed that :smile:. (It’s in the JuMP release-0.18 branch, but there isn’t an official 0.18.3 yet.)