Unsatisfiable requirements detected for package StringDistances

Travis tells me: All goes fine with Julia Version 1.1.0.

However with Julia Version 1.3.0-DEV.100 things are broken:

julia --check-bounds=yes --color=yes -e ‘using Pkg; Pkg.test(coverage=true)’
Updating registry at ~/.julia/registries/General
Updating git-repo https://github.com/JuliaRegistries/General.git
Testing …
Resolving package versions…
ERROR: Unsatisfiable requirements detected for package StringDistances [88034a9c]:
StringDistances [88034a9c] log:
├─possible versions are: [0.0.1-0.0.2, 0.1.0-0.1.1, 0.2.0-0.2.1, 0.3.0-0.3.2] or uninstalled
├─restricted to versions 0.3.2 by an explicit requirement, leaving only versions 0.3.2
└─restricted by julia compatibility requirements to versions: 0.3.0-0.3.1 or uninstalled — no versions left

I have no idea what “StringDistances” do or why they are required (I certainly did not add them manually to the requirements of my project).

What to do in such a situation?

Seems like you may have 0.3.2 pinned?

It is not needed to be pinned. Packages in your Project are “pinned” automatically (https://github.com/JuliaLang/Pkg.jl/issues/110).

This looks weird: https://github.com/JuliaRegistries/General/blob/e341d1c00e7fdaf467306a03c7a75ae0940fed2b/S/StringDistances/Compat.toml#L21. Why is it restricted to <= 1.1?

Fixed now:


Definitely not! I’ve never ‘pinned’ anything in my life. I don’t even know how it can be done.

Ah, in the Manifest.toml there is a “DocSeeker” which has in deps “StringDistances”, and yes, this has
version = “0.3.2”. So may I kill the “DocSeeker”?

As I posted, it’s fixed. Just do pkg> up.

1 Like