TLS Version is not supported MySQL error

Hi everyone,

I have an Azure MySQL Database I’m trying to connect to using:

DBInterface.connect(MySQL.Connection, host, user, pass, db = dbname);

host, user, pass and dbname are string inputs.

I’m receiving the error “TLS Version used does not meet minimal requirements for this server. Please use a higher TLS version and retry.”

It might just be me, but I can’t find any documentation about changing the TLS used for the MySQL package?


Hi Mitch, I am facing similar issue for azure mysql. Did you find solution to fix above. Thanks

It looks like it is a setting in your Azure control panel you can tweak

“We currently support TLS versions 1.0, 1.1, and 1.2. Setting a minimal TLS version ensures that subsequent, newer TLS versions are supported. We recommend setting the minimal TLS version to 1.2, after testing to confirm your applications support it, because it includes fixes for vulnerabilities found in previous versions. It’s also the highest TLS version supported in Azure Database for MySQL.”

1 Like

@lawless-m Thanks for your note, are you saying change the TLS setting to a lower one from 1.2? Changed it to 1.3 and 1.0 and it didn’t work… @nikhilk, unfortunately not.

I changed it to TLS 1.0 and it worked for me in the azure MySQL.


Tried again and it worked!

I’m glad that worked out, I didn’t know if it would.

Cheers for your help!

1 Like