Tensorboard doesn't find numpy

question
package

#1

I want to do some small projects with TensorFlow and it works fine, but can not make Tensorboard work. I’m also kinda new to Linux, so I’m not sure that everything I do is correct.
To start up Tensorboard easier I made a symbolic link to the …/.julia/v0.6/Conda/deps/usr/bin/tensorboard file in the /usr/local/bin/ folder (as suggested in the julia platform specific instructions to run julia).
When I try to start it with the command:

tensorboard --logdir=/tmp --port=8000

I get the following error:

Traceback (most recent call last):
  File "/usr/local/bin/tensorboard", line 7, in <module>
    from tensorboard.main import run_main
  File "/home/ubuntu/.julia/v0.6/Conda/deps/usr/lib/python2.7/site-packages/tensorboard/main.py", line 28, in <module>
    import tensorflow as tf
  File "/home/ubuntu/.julia/v0.6/Conda/deps/usr/lib/python2.7/site-packages/tensorflow/__init__.py", line 24, in <module>
    from tensorflow.python import pywrap_tensorflow  # pylint: disable=unused-import
  File "/home/ubuntu/.julia/v0.6/Conda/deps/usr/lib/python2.7/site-packages/tensorflow/python/__init__.py", line 47, in <module>
    import numpy as np
ImportError: No module named numpy

I don’t really know, if my Python/Conda environment has issues, or I’m missing something else. I also tried to rebuild the package, which didn’t help.


#2

It sounds like you need to install numpy.
Does

using Conda
Conda.add(“numpy”)

work?


#3

Yes, it worked! Thank you!