Sudden, strong increase in compilation times, that is fixed by emptying `~/.julia/compiled/`

As it says in the title.
Is this a known phenomenon?


  • Precompiling and loading a custom package of mine takes normally about 20 seconds max. One day, it started taking 130 seconds, without any substantial code changes. Calling other functions for the first time also took longer (e.g. loading a 3GB file with JLD2’s open: from ~20 s to ~50 s).
  • “What has changed between yesterday and today that might have caused this?”. I had updated some packages in my Manifest, and removed some dependencies (most notably the DifferentialEquations stack). I had also built a new sysimage with PackageCompiler.jl.
  • I tried fixing the compile-time increase by running without a custom system image; by reverting the old manifest and instantiating that; by rebooting. Those didn’t help.
    Then, (just to try anything) I emptied the entire ~/.julia/compiled/ directory.
    And that fixed it (both with or without sysimage, with both new or old Manifest).

Julia 1.8.1 on Windows 10.


any chance you running low on disk space?

Not direly; 80GB free atm.
Looking at my recycle bin, the old .julia/compiled/v.1.8/ dir was ~500MB. Current is ~50MB.