Strange ‘abstract_call’ messages before code running

Hi I have been encountering this problem for both Julia 1.5.3 and 1.5, under both Julia Pro and VS Code.
Whenever I ran codes in Julia, there will always be some strange messages in the terminal, like

inlineeval##kw at c:\Users\rmizf\.vscode\extensions\julialang.language-julia-1.0.10\scripts\packages\VSCodeServer\src\eval.jl:183 [inlined]
#61 at c:\Users\rmizf\.vscode\extensions\julialang.language-julia-1.0.10\scripts\packages\VSCodeServer\src\eval.jl:144
withpath at c:\Users\rmizf\.vscode\extensions\julialang.language-julia-1.0.10\scripts\packages\VSCodeServer\src\repl.jl:124
#60 at c:\Users\rmizf\.vscode\extensions\julialang.language-julia-1.0.10\scripts\packages\VSCodeServer\src\eval.jl:142
hideprompt at c:\Users\rmizf\.vscode\extensions\julialang.language-julia-1.0.10\scripts\packages\VSCodeServer\src\repl.jl:36
#59 at c:\Users\rmizf\.vscode\extensions\julialang.language-julia-1.0.10\scripts\packages\VSCodeServer\src\eval.jl:110
unknown function (ip: 000000005f0b6121)
with_logstate at .\logging.jl:408
with_logger at .\logging.jl:514 [inlined]
#58 at c:\Users\rmizf\.vscode\extensions\julialang.language-julia-1.0.10\scripts\packages\VSCodeServer\src\eval.jl:109
unknown function (ip: 000000005f0b15a3)
jl_apply at /cygdrive/c/buildbot/worker/package_win64/build/src\julia.h:1690 [inlined]
do_apply at /cygdrive/c/buildbot/worker/package_win64/build/src\builtins.c:655
jl_f__apply at /cygdrive/c/buildbot/worker/package_win64/build/src\builtins.c:669 [inlined]
jl_f__apply_latest at /cygdrive/c/buildbot/worker/package_win64/build/src\builtins.c:705
#invokelatest#1 at .\essentials.jl:710 [inlined]
invokelatest at .\essentials.jl:709
jl_apply at /cygdrive/c/buildbot/worker/package_win64/build/src\julia.h:1690 [inlined]
do_apply at /cygdrive/c/buildbot/worker/package_win64/build/src\builtins.c:655
macro expansion at c:\Users\rmizf\.vscode\extensions\julialang.language-julia-1.0.10\scripts\packages\VSCodeServer\src\eval.jl:27 [inlined]
#56 at .\task.jl:356
unknown function (ip: 000000002f14ed73)
jl_apply at /cygdrive/c/buildbot/worker/package_win64/build/src\julia.h:1690 [inlined]
start_task at /cygdrive/c/buildbot/worker/package_win64/build/src\task.c:705


There are hundreds of lines or such messages each time and I have to wait for about 2 minutes before the code could run normally. Is there anyone who knows how to solve this? I have tried Julia 1.0 and 1.2 and there is no such issue. My system is Windows 10.

Does this also happen in the REPL? What about using the normal Julia binaries together with Atom, rather than JuliaPro?

The same problem still happens.

It’s almost like a debugger is attached to the Julia process. How did you obtain Julia?

Hi I downloaded from Julia’s website

Sorry just to confirm, when you download the Julia 1.5.3 executable from the Julia website, do a clean install on Windows, open the REPL (by just double clicking on the Julia icon on your desktop), and run

julia> 2+2

you get back all of those messages above, instead of just 4?

In Powershell, what is the output of Get-ChildItem env: . I’m trying to see if there is anything in your environment that may be causing this.

You might want to delete your %USERPROFILE%\.julia folder or move it somewhere else as a test to see if it is anything in there.

You mentioned Julia Pro. Maybe try standard Julia: https://julialang.org/downloads/

Hi Mkitti,
The result is:

PS C:\Users\rmizf> Get-ChildItem Env:

Name                           Value
----                           -----
ALLUSERSPROFILE                C:\ProgramData
APPDATA                        C:\Users\rmizf\AppData\Roaming
CHROME_CRASHPAD_PIPE_NAME      \\.\pipe\crashpad_21976_WCLGACJCPMOJURNR
COLORTERM                      truecolor
CommonProgramFiles             C:\Program Files\Common Files
CommonProgramFiles(x86)        C:\Program Files (x86)\Common Files
CommonProgramW6432             C:\Program Files\Common Files
COMPUTERNAME                   CRI-PC44
ComSpec                        C:\Windows\system32\cmd.exe
DriverData                     C:\Windows\System32\Drivers\DriverData
GIT_ASKPASS                    c:\Users\rmizf\AppData\Local\Programs\Microsoft VS Code\resources\app\extensions\git\dist\askpass.sh
HOMEDRIVE                      C:
HOMEPATH                       \Users\rmizf
Julia                          C:\Users\rmizf\AppData\Local\Programs\Julia 1.5.0_2\bin
JUNORC_PATH                    C:\Users\rmizf\AppData\Local\JuliaPro-1.2.0-1\.atom
LANG                           en_US.UTF-8
LOCALAPPDATA                   C:\Users\rmizf\AppData\Local
LOGONSERVER                    \\WNS02
MASSDIR                        I:\WINMASS
Net                            NUSNET-III NT
NUMBER_OF_PROCESSORS           8
OneDrive                       C:\Users\rmizf\OneDrive
ORIGINAL_XDG_CURRENT_DESKTOP   undefined
OS                             Windows_NT
Path                           C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Windows\System32\OpenSSH\;C:\Program Files (x86)\Microsoft SQL Server\150\DTS\Binn\;C:\...
PATHEXT                        .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC;.CPL
PROCESSOR_ARCHITECTURE         AMD64
PROCESSOR_IDENTIFIER           Intel64 Family 6 Model 94 Stepping 3, GenuineIntel
PROCESSOR_LEVEL                6
PROCESSOR_REVISION             5e03
ProgramData                    C:\ProgramData
ProgramFiles                   C:\Program Files
ProgramFiles(x86)              C:\Program Files (x86)
ProgramW6432                   C:\Program Files
PSModulePath                   C:\Users\rmizf\Documents\WindowsPowerShell\Modules;C:\Program Files\WindowsPowerShell\Modules;C:\Windows\system32\WindowsPowerShell\v1.0\Modules
PUBLIC                         C:\Users\Public
SESSIONNAME                    Console
SystemDrive                    C:
SystemRoot                     C:\Windows
TEMP                           C:\Users\rmizf\AppData\Local\Temp
TERM_PROGRAM                   vscode
TERM_PROGRAM_VERSION           1.52.1
TMP                            C:\Users\rmizf\AppData\Local\Temp
UATDATA                        C:\Windows\CCM\UATData\D9F8C395-CAB8-491d-B8AC-179A1FE1BE77
USERDNSDOMAIN                  STF.NUS.EDU.SG
USERDOMAIN                     NUSSTF
USERDOMAIN_ROAMINGPROFILE      NUSSTF
USERNAME                       rmizf
USERPROFILE                    C:\Users\rmizf
VSCODE_GIT_ASKPASS_MAIN        c:\Users\rmizf\AppData\Local\Programs\Microsoft VS Code\resources\app\extensions\git\dist\askpass-main.js
VSCODE_GIT_ASKPASS_NODE        C:\Users\rmizf\AppData\Local\Programs\Microsoft VS Code\Code.exe
VSCODE_GIT_IPC_HANDLE          \\.\pipe\vscode-git-0515e26bdd-sock
windir                         C:\Windows

Hi Nilshg,
The result for both Julia 1.5.3 and Julia with VSCODE for the command is 4.
It seems that the error only happens when I run self-coded functions.

You seem to have many versions of Julia installed. There’s JuliaPro, Julia 1.5.0_2 and Julia 1.5.3.

Just so we’re clear, also give us the output of versioninfo()

Do you have a .julia\startup.jl ?

Is the error message that you posted the entire thing?

Hi Mkitti,
The versioninfo is as below.

Julia Version 1.5.3
Commit 788b2c77c1 (2020-11-09 13:37 UTC)
Platform Info:
  OS: Windows (x86_64-w64-mingw32)
  CPU: Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz
  WORD_SIZE: 64
  LIBM: libopenlibm
  LLVM: libLLVM-9.0.1 (ORCJIT, skylake)
Environment:
  JULIA = C:\Users\rmizf\AppData\Local\Programs\Julia 1.5.0_2\bin
  JULIA_EDITOR = "C:\Users\rmizf\AppData\Local\Programs\Microsoft VS Code\Code.exe"
  JULIA_NUM_THREADS =

I did not find starup.jl.

Hi what I posted is not the entire thing as there were too many lines of messages.
The beginning of the message is like below, which I copied from JuliaPro Terminal
( I did not manage to copy the error message using VScode as the message passed so quickly)

Internal error: encountered unexpected error in runtime:
StackOverflowError()
jl_subtype_env at /cygdrive/d/buildbot/worker/package_win64/build/src\subtype.c:1864
jl_subtype_env at /cygdrive/d/buildbot/worker/package_win64/build/src\subtype.c:1847 [inlined]
jl_subtype_matching at /cygdrive/d/buildbot/worker/package_win64/build/src\subtype.c:3410
jl_typemap_entry_assoc_by_type at /cygdrive/d/buildbot/worker/package_win64/build/src\typemap.c:462
ml_matches at /cygdrive/d/buildbot/worker/package_win64/build/src\gf.c:2799
jl_matching_methods at /cygdrive/d/buildbot/worker/package_win64/build/src\gf.c:1891
_methods_by_ftype at .\reflection.jl:861 [inlined]
#216 at .\compiler\abstractinterpretation.jl:57 [inlined]
get! at .\iddict.jl:152
jfptr_getNOT._20261.clone_1 at C:\Users\rmizf\AppData\Local\JuliaPro-1.5.2-1\Julia-1.5.2\lib\julia\sys.dll (unknown line)
abstract_call_gf_by_type at .\compiler\abstractinterpretation.jl:55
abstract_call_known at .\compiler\abstractinterpretation.jl:904
abstract_call at .\compiler\abstractinterpretation.jl:926
abstract_call at .\compiler\abstractinterpretation.jl:911
abstract_eval at .\compiler\abstractinterpretation.jl:1005
typeinf_local at .\compiler\abstractinterpretation.jl:1270
typeinf_nocycle at .\compiler\abstractinterpretation.jl:1326
typeinf at .\compiler\typeinfer.jl:12
typeinf_edge at .\compiler\typeinfer.jl:484


This is the most informative line so far.

1 Like

Does this happen with simple self-coded functions like f(x) = x*x ? Or particular ones?

It seems your self-coded functions seems to be running out of memory. Can you share with us a minimum working example of a self-coded function that causes these issues?

Hi the error does not occur for functions like f(x) = x*x.
There is no complicated calculation in the functions. And I can get the results from these functions after the end of the messages.
For Julia 1.0 and 1.2 versions, I do not encounter such issues either.

Do you have any large tuples?

I think we really need a Minimum Working Example (MWE) that demonstrates the issue to progress further. Could you try to isolate what lines in your function are causing the issue?

2 Likes