StatsBase vs Statistics


I am wondering whether the naming of StatsBase and Statistics is entirely logical. StatsBase, despite its name, is the “more optional” package. Statistics is included in the base. StatsBase needs to be Pkg.added. maybe they are misnamed?!


StatsBase precedes the reorganization of Base code to Statistics. It is still the basic statistics package for things that go beyond the standard library.


StatsBase is most likely going to be moved in part to Statistics, and in part to other packages (like StatsModels). See e.g.


if I understand correctly, julia will be evaporating StatsBase, so its misleading name will disappear. this is a good choice IMHO.