Signal (11): Segmentation fault when launching MATLAB process

I am trying to call MATLAB from julia, but I get a segmentation fault:

julia> using MATLAB
 │ Package MATLAB not found, but a package named MATLAB is available from a
 │ registry. 
 │ Install package?
 │   (@v1.8) pkg> add MATLAB 
 └ (y/n/o) [y]: 
    Updating registry at `~/.julia/registries/General.toml`
   Resolving package versions...
    Updating `~/.julia/environments/v1.8/Project.toml`
  [10e44e05] + MATLAB v0.8.3
    Updating `~/.julia/environments/v1.8/Manifest.toml`
  [10e44e05] + MATLAB v0.8.3

julia> mat"1+1"

signal (11): Segmentation fault
in expression starting at REPL[2]:1
Allocations: 79472235 (Pool: 79433134; Big: 39101); GC: 43

This never happen on the same computer when I was running windows. I am now running Linux Mint. Any idea what could be the cause?

Have you seen the warning about Matlab 2022a/b on github?

1 Like

No, I have not. Thanks :slight_smile:

If you don’t have older MATLAB that works, then you can call Octave instead. At least indirectly by calling through Python to a package for that as I did… it’s a hassle but worked (and I had to disable threading OpenBLAS threading in Octave with an ENV var to get around a bug). There is OctCall.jl but it seems unchanged, and was immature when I tried to use it.