SerialPorts


#1

SerialPorts.jl doesn’t work with Julia version 1+. I need to control a laser device through a serial port. Any suggestions?


#2

Have you tried https://github.com/andrewadare/LibSerialPort.jl ?


#3

Alternatively, if you are willing to use Julia, 0.6, SerialPorts.jl works.


#4

I’ve not used it myself, but it looks like SerialPorts.jl version v0.2.0 supports 1.0 — https://github.com/JuliaIO/SerialPorts.jl/releases

What trouble are you having with it?


#5

+1 for https://github.com/andrewadare/LibSerialPort.jl I am using this on a variety of devices and had no issues so far. Advantage is that it does not require Python.


#6

Sorry for the late reply. This is what I get on Julia 1.0.3:

(serial) pkg> st                                                                               
    Status `C:\Users\michele.zaffalon\private\serial\Project.toml`                             
  (empty environment)                                                                          
                                                                                               
(serial) pkg> add SerialPorts                                                                  
  Updating registry at `C:\Users\michele.zaffalon\.julia\registries\General`                   
  Updating git-repo `https://github.com/JuliaRegistries/General.git`                           
 Resolving package versions...                                                                 
ERROR: Unsatisfiable requirements detected for package SerialPorts [5d0f9de7]:                 
 SerialPorts [5d0f9de7] log:                                                                   
 ├─possible versions are: [0.0.1-0.0.7, 0.1.0] or uninstalled                                  
 ├─restricted to versions * by an explicit requirement, leaving only versions [0.0.1-0.0.7, 0.1.0]                                                                                             
 └─restricted by julia compatibility requirements to versions: uninstalled — no versions left  
                                                                                               
(serial) pkg> st                                                                               
    Status `C:\Users\michele.zaffalon\private\serial\Project.toml`                             
  (empty environment)                                                                          

#7

I had that problem a while ago and opened an issue in SerialPorts.jl here. The trich is to explicitly download the master branch with:

]add SerialPorts#master

It worked for me and I already tried in Windows and Linux OS’s.