Segmentation fault when installing packages

Hello everyone,

I don’t know since when that happens but I just noticed that I can not install new packages anymore.

If I run “Pkg.add(“LightGraphs”)” for example, Julia crashes:

These are the packages that are already installed:

[6cde8614] BlockDecomposition v1.2.0
[88b4ec78] Coluna v0.3.0 #master (https://github.com/atoptima/Coluna.jl)
[60bf3e95] GLPK v0.12.1
[4076af6c] JuMP v0.21.1
[b8f27783] MathOptInterface v0.9.13 #master (https://github.com/JuliaOpt/MathOptInterface.jl)

It might be because one of the installed packages, but I did not really want to remove any because I am afraid I will not be able to reinstall them.

Does anyone have any idea what the reason for this problem could be or how it can be solved?

It will be great if anyone can help me!

Best regards,

David

How did you install Julia?

1 Like

Using the graphical package manager in Manjaro (so Pamac version 9.4.2-1).

This is a known issue with the package manager in Manjaro.

Try using the official binaries from https://julialang.org

1 Like

Fantastic, it works now!

Thank you so much for you help. I don’t know what I would have done without you!

Or use your favourite AUR helper to install https://aur.archlinux.org/packages/julia-bin/