Scatter3d and pyplot backend in Plots.jl

Hello! I’m having a very strange issue trying to visualize a 3D scatterplot using the pyplot backend in Plots.jl. The Z-axis position of my inputted coordinates do not seem to register, and only stays on the 0 value, while the X and Y positions are registered properly. No error message comes up, and I’ve tried rebuilding PyCall and Plots with no change in my issue. Has anyone seen something like this before?

For example, simply inputting scatter3d([1, 5, 7], [2, 4, 5], [-4, 23, 4]) gives the following output:

And similar issues with much larger value sets that I am trying to visualize. All other backends that I have tried (gr, pgfplotsx, and plotlyjs) display the Z coordinates just fine.

That works fine for me on Plots 1.9.0

I have the same issue with pyplot, everything else works fine though.

What is your version of Plots?

I was using Plots 1.9.1.

Some good (and strange) news: I manually updated and rebuilt PyCall and PyPlot via package manager, and even though the return message noted that no changes were made during the update process, it seems to have resolved to issue. I’m now using Plots 1.9.1, PyCall 1.92.1, and PyPlot 2.9.0, for anyone else who may have had this issue.

Thanks for the troubleshooting!