REQUIRE - set upper limit in package

How do I set an upper limit in REQUIRE in my package?
Example is that I want to use JuMP v0.18 and NOT 0.19.
When adding JuMP 0.18.5 to my REQUIRE, travis-ci still gives me an error because it uses 0.19.
Thanks already in advance

JuMP 0.18 0.19.


Thank you, that worked. Do you know why does this exclude 0.19?
Intuitively, if I just looked at JuMP 0.18 0.19, it would read to me as if I were to allow 0.18 AND 0.19, and not 0.18 and NOT 0.19?
Also, is there any documentation on this? I was unable to find that anywhere.
Thanks again.

The REQUIRE format is defined to take closed/open intervals of versions. Seemed like a good idea but people seem to find it confusing.


Documentation of the REQUIRE format can be found here: Note that this is from the Julia 0.6 version of the manual. REQUIRE will eventually no longer be required for Julia 1.0 and up, but we’re currently in an awkward transition period where REQUIRE is still useful and necessary but not actually part of the Julia 1.0 manual.

1 Like

But we’re getting there! See: