Request help on PATHSolver.jl

I wanted to solve complementarity problem using PATHSolver, and kept getting the error:
“could not load library “./julia/datadeps/libpath50/libpath50.dylib”
dlopen(.julia/datadeps/libpath50/libpath50.dylib, 0x0001): tried: ‘.julia/datadeps/libpath50/libpath50.dylib’ (mach-o file, but is an incompatible architecture (have ‘x86_64’, need ‘arm64e’)), ‘/usr/local/lib/libpath50.dylib’ (mach-o file, but is an incompatible architecture (have ‘x86_64’, need ‘arm64e’)), ‘/usr/lib/libpath50.dylib’ (no such file)” . Can someone please guide me through this? I get that it is saying ‘libpath50.dylib’ version is not compatible with my machine, but where can I find the compatible version? Thank you in advance,

Are you using an M1 or M2? PATHSolver does not support that: PATHSolver doesn't build on aarch64-apple-darwin · Issue #61 · chkwon/PATHSolver.jl · GitHub

You’ll need to use the Rosetta build of Julia instead. (The “macOS x86 (Intel or Rosetta)” link from Download Julia)

Thank you. With the Rosetta version, the solver worked.