Repl in Juno, type enter and report an error

I successfully installed Julia, atom, and Juno (including july-client, etc.)
julia version 0.6.4
It runs successfully directly from the command line.

But in the repl in atom, pressing enter causes the following error

Press Enter to start Julia. 
ERROR: LoadError: UndefVarError: @error not defined
 [1] include_from_node1(::String) at .\loading.jl:576
 [2] include(::String) at .\sysimg.jl:14
 [3] process_options(::Base.JLOptions) at .\client.jl:305
 [4] _start() at .\client.jl:371
while loading C:\Users\*****\.atom\packages\julia-client\script\boot_repl.jl, in expression starting on line 1

I’ve tried to reinstall july-client, and Julia Path has been set.
How to solve it? Thank you in advance.

Attach another picture

Any reason why you choose such an old Julia version? To me it looks like the error would vanish if you switch to a newer (>=1.0) version of Julia.

1 Like

We’ve been trying to keep julia-client compatible with Julia 0.6, but recently merged a PR that broke that. Should be fixed again by this.

1 Like

Thanks a lot!

Because the code I want to run is based on Julia 0.6.I didn’t know if using the latest version would cause compatibility problems, so I chose this old version.
I tried your suggestion, updating Julia version did solve the problem.Thanks a lot.

1 Like