Question with DiffEqBiological

Hi all,

I have been running into a problem with the DiffEqBiological package. The following code always returns “ERROR: LoadError: Base.Meta.ParseError(”+1")":

rn = @reaction_network begin
1.0, 0 --> M
end

whereas the following code works fine:
rn = @reaction_network begin
1.0, 0 --> M
1.0, M --> 0
end

Does anyone happen to know the cause of the error?

That’s :man_shrugging: . Please open an issue.

This works fine for me on the latest release. Have you tried updating?

Thanks @isaacsas. I tried Pkg.update(“DifferentialEquations”) and Pkg.update(“DiffEqBiological”) , which does not update the package. Finally, I tried Pkg.update(), which updates all the packages and solves the problem.

This is exciting, but why does “Pkg.update(“DifferentialEquations”)” not work?

@ChrisRackauckas I will open an issue about updating packages.

It’s probably because you had a dependency that needed updating as well. That shouldn’t get an issue.

Thanks @ChrisRackauckas. Is there any chance Julia could update the dependencies during the update of an individual package?

I have already created an issue… If I do not hear anything, I will close the issue.