Bug with Pkg up? (for DifferentialEquations.jl)

I do:

(@v1.9) pkg> up --major DifferentialEquations@7.1.0

It took a lot of time, updated at least some other packages, even precompiled DifferentialEquations, but it’s still at older version. So if this is the wrong command, shouldn’t at least complain about the @7.1.0? Or what is the point of that optional part? I can do this with a space in front, and I think it means the same, and also skip --major which I believe might be the default anyway. If I do this again, any variant, it’s fast, as in seemingly nothing to do.

(@v1.9) pkg> st --outdated
Status `~/.julia/environments/v1.9/Project.toml`
⌅ [4fba245c] ArrayInterface v3.1.34 (<v5.0.7): DelayDiffEq, DiffEqBase, DiffEqJump, EllipsisNotation, LoopVectorization, ModelingToolkit, OrdinaryDiffEq, Polyester, PreallocationTools, SparseDiffTools, StochasticDiffEq, StrideArraysCore, VectorizationBase
⌃ [0c46a032] DifferentialEquations v6.18.0 (<v7.1.0)
⌅ [1dea7af3] OrdinaryDiffEq v5.61.3 (<v6.10.0): DifferentialEquations, StochasticDiffEq

However, this didn’t work before (or after):

(@v1.9) pkg> add DifferentialEquations @7.1.0
   Resolving package versions...
ERROR: Unsatisfiable requirements detected for package Interpolations [a98d9a8b]:
 Interpolations [a98d9a8b] log:
 ├─possible versions are: 0.3.6-0.13.6 or uninstalled

[long list skipped, shouldn't I get similar indication with up?]
1 Like

Thanks, it seems not just that the docs are wrong, also that up should warn you that it didn’t actually update to the latest version, if no version specified, and if one is provided, should just fail (if version provided I see it’s just ignored “@ does nothing.”).

At least I add packages once, and would think the up is then the go-to command. Until fixed, protip, add can be your up