Question about Franklin.jl

I’m creating a website with Franklin.jl. However, after restarting my computer, the following message appears in the REPL when I try to modify the file:

julia> using Franklin

julia> serve()
┌ Franklin Warning: in <config.md>
│ No 'config.md' file found. It is recommended to keep one.
│
│ Relevant pointers:
│ - workflow and folder structure: https://franklinjl.org/workflow/
└
ERROR: ArgumentError: The current directory doens't  have a `_layout` or `_css` folder, if you are using the old folder structure, please add `@def folder_structure = v"0.1"` in your config.md; otherwise, change directory to a valid Franklin folder.
Stacktrace:
 [1] serve(; clear::Bool, verb::Bool, port::Int64, single::Bool, prerender::Bool, nomess::Bool, is_final_pass::Bool, no_fail_prerender::Bool, eval_all::Bool, silent::Bool, cleanup::Bool, on_write::Franklin.var"#217#220", log::Bool, host::String, show_warnings::Bool, launch::Bool) at C:\Users\adeil\.julia\packages\Franklin\D9flx\src\manager\franklin.jl:96
 [2] serve() at C:\Users\adeil\.julia\packages\Franklin\D9flx\src\manager\franklin.jl:66
 [3] top-level scope at REPL[14] :1 

How should I proceed to continue modifying the file?

Hello,

You seem to not be running this from the right place.

Say you have a folder myWebsite on your computer then you have to

julia> cd("path/to/myWebsite")
julia> serve()

you can check what your current working directory is with

julia> pwd()

the error is telling you that the current working directory does not seem to be a Franklin directory.

Ps: there’s a typo in the error message… I’ll fix this. fixed on master

1 Like

Hi,
Can you see my repository and help me set the prepath?

Actually what you have seems fine. On GitHub, in the settings of that repository, under “GitHub-pages” please check that it’s the gh-pages branch that is selected. It should look like this:

I suspect that at the moment it’s set to “main”.

(in your repository you can check that the gh-pages branch is correct: it has the right index.html with the right paths, so all that is fine)

2 Likes

Thank you very much for the quick and polite response. I modified Branch, but nothing happened. You’re still wrong.

it takes a minute to propagate, your page is now online.

1 Like

Thank you so much for your help. It worked really well!

1 Like

@tlienart, what to do when the gh-pages option does not appear?

Your repo has a branch master (old repos from GitHub) but the deploy script quotes the new repos from GitHub with a branch main. I’ve submitted a PR to your repo.

1 Like

Happy Birthday @tlienart! :partying_face:

3 Likes

Many happy returns of the day! Happy birthday, @tlienart!

3 Likes