Proper way to install Julia with `OPENBLAS_NUM_THREADS=1`

Related to: Odd thread calling behavior on HPC

I’ve been experiencing some issues on our uni’s HPC due to OpenBLAS thread calling (see link to related discussion above). The issue can be resolved by just adding/modifying an environment variable (export OPENBLAS_NUM_THREADS=1). Ideally, I’d like to install Julia with that flag already activated.

Is there an easy way to do this using a) juliaup and b) using a pre-built binary?


Surely it is easy to put this export statement in your .bashrc

Yeh that’s fair, but I like to sync my dotfiles across platforms and I don’t necessarily want that flag everywhere. So if there’s a way to specify it during installation that’d be nicer.

I would just but it as an export statement in the slurm file.

Alright, I’ll just stick with that for now, thanks!