Problems with BSON

This has been discussed before, but I can’t say that I have fully understood all intricacies of the problem.

I try to load an object (flux model) with BSON.@load "/pathy/path" model. I have also tried to load it with bson_object = BSON.load("/pathy/path"). Both of this give me:

BoundsError: attempt to access DataType at index [1]

I can, however, use BSON.parse without error, but in this case I don’t know what to do with the thing that is returned.

Looking at other topics I found this:
Error on load DataFrame with BSON

Here it says that one has to be consistent with what version of DataFrames one uses. Is this true? Because my problem seems identical and I don’t use DataFrames at all. I suspect it’s the version of BSON and/or Julia.

The models are saved some time ago from notebooks. I run the loading in notebooks. All of the mentioned notebooks reside in a directory called v1 and are marked to use a 1.6 kernel. This directory has its own Project.toml which is activated explicitly in each notebook in the first cell. In other directories I use other versions of Julia and have other environments.

Can this save/load incompatibility arise in spite of these precautions? What can I do about it?

Can some “forensics” be used on the bson-files or any other files to expose wherein
the version conflict (if indeed that is what it is), lies?

I’m asking this because I want to placate an article reviewer by running some more experiments and I only have a very limited time to revise my article, so any help would be greatly appreciated.

Just some ideas to get started:

What is the output of


This output is perhaps not readable enough because it is truncated.
You may try


(which again maybe is not readable because output is huge) and look for some object of type DataType or any hint in that direction which is related to the BoundsError you get.