Problems using QuickDraw

I saw this package/talk on how to make deployable stand-alone Julia Apps using Quickdraw*:


and here: Quickdraw: The simplest Julia package deployment system :: JuliaCon 2023 :: pretalx

The Github demo using minesweeper worked like charm, but when I tried to use a local project, I get this confusing errorfrom Pkg (and yes, the path does exist).

Any ideas?

julia version 1.9.3
This might take a while.
  Activating new project at `~/.julia/environments/MakieWald-1d`
ERROR: Path `/Users/MyAccount/Documents/Development/Julia/Makie-animation/Tutorial_02x10/MakieWald-1d.jl` does not exist.
 [1] pkgerror(msg::String)
   @ Pkg.Types /Applications/
 [2] handle_repo_add!(ctx::Pkg.Types.Context, pkg::Pkg.Types.PackageSpec)
   @ Pkg.Types /Applications/
 [3] handle_repos_add!(ctx::Pkg.Types.Context, pkgs::Vector{Pkg.Types.PackageSpec})
   @ Pkg.Types /Applications/
 [4] add(ctx::Pkg.Types.Context, pkgs::Vector{Pkg.Types.PackageSpec}; preserve::Pkg.Types.PreserveLevel, platform::Base.BinaryPlatforms.Platform, kwargs::Base.Pairs{Symbol, Base.TTY, Tuple{Symbol}, NamedTuple{(:io,), Tuple{Base.TTY}}})
   @ Pkg.API /Applications/
 [5] add(pkgs::Vector{Pkg.Types.PackageSpec}; io::Base.TTY, kwargs::Base.Pairs{Symbol, Union{}, Tuple{}, NamedTuple{(), Tuple{}}})
   @ Pkg.API /Applications/
 [6] add(pkgs::Vector{Pkg.Types.PackageSpec})
   @ Pkg.API /Applications/
 [7] add(; name::Nothing, uuid::Nothing, version::Nothing, url::String, rev::Nothing, path::Nothing, mode::Pkg.Types.PackageMode, subdir::Nothing, kwargs::Base.Pairs{Symbol, Union{}, Tuple{}, NamedTuple{(), Tuple{}}})
   @ Pkg.API ./boot.jl:0
 [8] top-level scope

P.S. I hate the name “QuickDraw”, because (1) it is the name of an old MacOS API, and (2) it is non-obvious what the package does.