Problem with Plotting

Hey everyone,

I tried to plot some graphs today, but somehow the font for the labels is not sharp and the commands for the fontsize get ignored. I have tried downgrading Plots to 1.22, but that did not help. I also upgraded to 1.7rc3, which did nothing. It seems that Vegalite also ignores fontsize keywords.

Here is the picture


and the code:

plot(df.Date, df.PHPOE, label = "", color = :black, xlabelfontsize = 22, ylabelfontsize = 22, legendfontsize = 22)
julia> versioninfo()
Julia Version 1.7.0-rc3
Commit 3348de4ea6 (2021-11-15 08:22 UTC)
Platform Info:
  OS: Windows (x86_64-w64-mingw32)
  CPU: 11th Gen Intel(R) Core(TM) i7-11700 @ 2.50GHz
  LIBM: libopenlibm
  LLVM: libLLVM-12.0.1 (ORCJIT, icelake-client)

Packe status:

  [a98d9a8b] Interpolations v0.13.4
  [b964fa9f] LaTeXStrings v1.3.0
  [e1d29d7a] Missings v1.0.2
  [429524aa] Optim v1.5.0
  [8314cec4] PGFPlotsX v1.4.1
  [9b87118b] PackageCompiler v2.0.2
  [d96e819e] Parameters v0.12.3
  [91a5bcdd] Plots v1.22.7 ⚲
  [fcd29c91] QuantEcon v0.16.3
  [1a8c2f83] Query v1.0.0
  [295af30f] Revise v3.1.20
  [f2b01f46] Roots v1.3.9
  [efcf1570] Setfield v0.7.1
  [2913bbd2] StatsBase v0.33.13
  [4c63d2b9] StatsFuns v0.9.13
  [112f6efa] VegaLite v2.6.0
  [fdbf4ff8] XLSX v0.7.8
  [e88e6eb3] Zygote v0.6.30
  [ade2ca70] Dates
  [9a3f8284] Random
  [8dfed614] Test

To improve the resolution try: using Plots; gr(dpi=600)
For the font size try plot keyword argument: tickfontsize=22

1 Like

Thank you, I just messed up the keywords :smiley:

Could this be related to the new version of vscode having plots be png rather than svg by default?