Problem in cloning or adding OpenCV.jl


#1

julia> Pkg.clone(“http://github.com/maxruby/OpenCV.jl”)
INFO: Cloning OpenCV from http://github.com/maxruby/OpenCV.jl
ERROR: OpenCV already exists
Stacktrace:
[1] clone(::String, ::SubString{String}) at ./pkg/entry.jl:193
[2] (::Base.Pkg.Dir.##4#7{Array{Any,1},Base.Pkg.Entry.#clone,Tuple{String}})() at ./pkg/dir.jl:36
[3] cd(::Base.Pkg.Dir.##4#7{Array{Any,1},Base.Pkg.Entry.#clone,Tuple{String}}, ::String) at ./file.jl:70
[4] #cd#1(::Array{Any,1}, ::Function, ::Function, ::String, ::Vararg{String,N} where N) at ./pkg/dir.jl:36
[5] clone(::String) at ./pkg/pkg.jl:169

I am getting trouble in cloning, adding removing OpenCV.jl , its been marked as an unregistered package on running Pkg.status().
If anyone could help me with this at the earliest ?


#2

Please post your code by copy-and-paste rather than a screenshot. Screenshots are harder to read and can’t be searched for by other people in the future.

I think your problem is that you did Pkg.init("http://...OpenCV.jl.gi"). That’s not what Pkg.init() is used for. Pkg.init() initializes your Julia package directory, and passing an argument to it tells Julia to use that URL instead of https://github.com/JuliaLang/METADATA.jl when looking up package information. In essence, Pkg.init("http://...OpenCV.jl") tells Julia that it should look in the OpenCV repo for the version information of every Julia package.

You will, at the very least, need to fix that. You can fix your METADATA by doing:

Pkg.init()

and then I would suggest removing ~/.julia/v0.6/OpenCV and repeating the Pkg.clone("http://github.com/maxruby/OpenCV.jl") step.


#3

Also I would strongly recommend deleting the screenshots in your original post because your transparent terminal background is revealing quite a lot of your personal Facebook page which you presumably do not want to post in public.


#4

Thank you @rdeits for your concern. I shall take care of your advice regarding use of screen shot.
Moreover Pkg.init() was the last choice. I tried removing .julia entirely and reconstructing it. Still, was troubled by the same error.


#5

That’s confusing: if you deleted all of .julia then you should not be seeing OpenCV already exists. Can you please post exactly what you did, starting from when you deleted .julia and what the error messages were?

Also, please see: PSA: how to quote code with backticks