Pluto not accepting repl packages

When I add a package in the repl I can see it in Jupyter and my editor, but not in Pluto. I hate to dupe packages and waste limited disk space. Is there any way to make Pluto coordinate?

you’re not duplicating packages because there’s only one source code depository, what is maintained independently is Manifest.toml which only records the environment.


Thanks. But why won’t Pluto recognize what I load in the REPL?

because each pluto notebook now records its own environment🎁-Package-management


To add to jling’s answer. You can activate an enviroment manually, e.g.
import Pkg; Pkg.activate(). (Of course, this has disadvantages as well.)
See: Package-management advanced-set-up-an-environment-with-pkgactivate

1 Like

The recommend way to use Pluto is not manually adding any package at all. Just type using MyPkg or import MyPkg and Pluto automatically takes care of installing packages and pinning versions for reproducibility.
You only need to manually add packages if they are not in a Registry (General or custom registry).

1 Like