Plots not working on julia

Hi!

I’m trying to plot with the package “Plots”. I did:
using Plots
x = 1:10; y=rand(10)
plot(x,y)

but I get the next error:


I’m not sure why is not getting the GKSFONT.DAT.

(I’ve already done Pkg.add(“Plots”), and it appeared to be added without errors, but is not working though).
Any help is welcome!

Can you try ]build GR?

1 Like

With Windows 10 and Julia 1.6.2 I get this.
I have no idea if this is significant!

julia> using Plots

(process:22120): GLib-GIO-WARNING **: 14:03:31.886: Unexpectedly, UWP app 38526MediaLife.ZipPlus_2.0.4.0_x86__1crh1k73ty8mg' (AUMId 38526MediaLife.ZipPlus_1crh1k73ty8mg!ZipExtractor’) supports 89 extensions but has no verbs

(process:22120): GLib-GIO-WARNING **: 14:03:34.406: Unexpectedly, UWP app 3138AweZip.AweZip_1.4.8.0_x86__ffd303wmbhcjt' (AUMId 3138AweZip.AweZip_ffd303wmbhcjt!App’) supports 168 extensions but has no verbs

Plots is failing to precompile here on a Windows 10 machine.

Regards,
Greg

Still having the same error though

Any idea of how to fix it?

From an old issue Error: GKS: can't connect to GKS socket application · Issue #1649 · JuliaPlots/Plots.jl · GitHub

Same issue reported here. At least for me on Windows 10, the problem was that the antivirus blocked gksqt.exe. Unblocking makes it run ok.

But the error is not the same, I’m having trouble with finding GKSFONT.DAT, the issue you are telling me says that GKS is not in proper state. I tried without the antivirus working though and the error is still the same.

You error report contained the line: GKS: can’t connect to GKS socket application

I tested Plots on Windows 10 and I can plot OK. Really sorry I can’t help solve this one.
Have you tried remove Plots then add Plots?

Yes :frowning:, it still jumps the same error